ALL SUBJECT AREAS INCLUDED

Completed

Comments

1 comment

  • Avatar
    Happy Man Community
    • I believe that this is a bug and I have reported it as such.  As far as Iknow, this is being looked at by level 2.

      • Edwy_Erwin

        well whatever level looked at it, they didn't give a .... about it since it's STILL a known issue in 9.6

        • GarryG

          I just reviewed this issue and found that when I was testing R9.6 beta, this issue was resolved.  It IS FIXED in R9.6..   I tested it again and found it to be working as expected when running the SA report with the filter to select at runtime.  If I choose 2 out of X number of available SAs, I now only get the 2 I requested and not the rest of the SA names with no details as before.

           

          At this point I guess Neil can mark this as IMPLEMENTED and no longer wish listed.

          • Edwy_Erwin

            So how come in the know issues in CA website I see this :

            Release Notes Release 9.6.0

             

            Unwanted Result Rows in Report

            In a Subject Area report, suppose the Subject Area name is included in the report and the diagram name is specified at run time. The report lists all Subject Areas instead of the Subject Area that corresponds to the selected diagram.

            • GarryG

              Did you actually try to see if is fixed or not or just read it?  Perhaps they just messed up the documentation and forgot to remove this from say R9.5 documentation they cloned and changed for R9.6?

               

              When I was testing it was fixed unless they decided to unfix it when it went GA

               

              CAs documentation is not always the best or even correct at times.

              • Edwy_Erwin

                Did you actually try to see if is fixed or not or just read it ?

                 

                Seriously ? What you are basically telling me is NOT TO TRUST ANYTHING CA SAYS because their documentation is **** ?

                Ok I got the message.

                • GarryG

                  No I'm not saying that at all. Sometimes the documentation is not always updated to reflect things that change in the product.  If it is a documentation problem, then report it to CA.

                   

                  I have tried this several times, and the report is now working as I suspect it should.  Again, if there is something else wrong with the report, then you should report it to CA as a bug.  They fix bugs between releases.

                   

                  What problem are you experiencing?

    • TheovanWestrienen

      I am testing R9.64.1. As with the Idea of Pinned Reports which is marked as delivered, also this change appears not to be delivered.

      I do not experience any difference when running a Report Designer report, with a filter option selected of Specify Diagrams at runtime. The result of this report is exactly the same when comparing 9.5.2 model and report with the same model and report in 9.64.1.

      Which means:

      - the HTML report shows all SA's not only the selected SA's

      - the SA's are not sorted (or rather: they are sorted in a mystical way, probably on something like date created)

       

       

      I regard this Idea as not delivered

      • GarryG

        Hi Theo...

         

        I just tried  this in R9.64.01 and it is working for me. I have a model with around a hundred SAs in it and I have a subject area report that lists just entity name and table name by SA, and filter is specify at run time.  I selected one SA and ran the report and its results were 100% as I expected.

         

        Does this happen for every model or only specific one?  Try creating a new R9.64.01 model and see if it happens with it as well. .

         

        Is it [possible you have some model corruptions?  I have had several cases where internal model corruptions (probably caused by migrating models through many releases of ERwin) have caused weird and unexpected things to happen.   You can check for any corruptions by doing a CC to blank model.

         

        Gees.. I'm starting to sound like level one support! 

         

        Here is a screen shot of what I have :  You can see that the report shows only one of the SAs in a model with many.

        Report screen shot.jpg

      • GarryG

        Sorry .. forgot to include the screenshot for the HTML run of this report as well.   Here it is... working as expected. One Sa, and details for it onlyhtml report - SA ent table.jpg

      • GarryG

        OK... I did not read your first message completely and missed the HTML output for ERw diagrams.   I will tty that now and report as well.   Are we having fun yet?  Stay tuned.

        • Edwy_Erwin

          just for the sake of it and to replicate the issue I had for example, can you please include the data model picture in your html report (using graphical members) and see if the result is still OK

          Thanks,

          • GarryG

            ....  Yup and here are the results.. report first ... as expectedhtml report with er diagrams at run time.jpg

             

             

            here is the E diagrams output .. again as requested and expected.

             

            HTML diagram.jpg

             

             

             

            And finally here is the report ... as constructedSA report with ER diagrams at runtime.jpg

            • TheovanWestrienen

              OK, I'll add some screenprints.

              I have a report for which I select diagrams at runtime:

               

              I select 2 diagrams (from in total several dozens of possible diagrams):

               

              My HTML report looks like this:

              (same in 9.5.2 as well as in 9.64) It shows ALL SA's, and indeed, just the diagrams I selected.

              Am I missing something?

              I was expecting just 2 diagrams + SAs. I get dozens, and on top of it all sorted in a uncomprehensable way..

              - Why am I seeing so many items in the list?

              - Is there an option to influence / steer the sort order of the report?

              • GarryG

                You did not filter on Subject area, only the diagrams.  Diagrams belong with SA, so if you specify the SA and Diagram filters (at runtime you get the correct output as you want.   see screenshot.  Without the SA filter on, you get all SAs (empty with no diagrams) cuz you didn't limit them, but you only get the diagrams you specified  I was going to add the .erps file as a sample but it seems you can't attach a file here

                 

                screen shot for theo.jpg

Please sign in to leave a comment.

Powered by Zendesk